Partial outage
Incident Report for ActiveCampaign
Resolved
This incident has been resolved.
Posted Aug 27, 2015 - 19:34 CDT
Investigating
We are investigating degraded performance at this time that affects a segment of accounts.
Posted Aug 27, 2015 - 19:02 CDT