Connectivity issues for some accounts
Incident Report for ActiveCampaign
Resolved
All services are nominal.
Posted 10 months ago. Feb 03, 2017 - 08:04 CST
Investigating
Some accounts are experiencing connectivity issues. We are currently investigating.
Posted 10 months ago. Feb 03, 2017 - 07:46 CST