Partial account outages
Incident Report for ActiveCampaign
Resolved
This incident has been resolved.
Posted Apr 11, 2014 - 16:37 CDT
Investigating
We are looking into account outages that are affecting a very limited number of accounts.
Posted Apr 10, 2014 - 16:16 CDT