Increased Platform Latency
Incident Report for ActiveCampaign
Resolved
We have taken action to alleviate the increased latency and service has returned to normal.
Posted Jan 29, 2020 - 13:22 CST
Investigating
We are investigating an issue causing increased latency across the platform beginning at 6:46 PM UTC, Wednesday January 29.

Next Update: 7:30 PM UTC.
Posted Jan 29, 2020 - 13:00 CST
This incident affected: US Region (Platform Availability).