Contact Page Loading Issues
Incident Report for ActiveCampaign
Resolved
The issue impacting the Contact Page not loading has been fully resolved.
Posted about 1 month ago. Aug 14, 2019 - 18:35 CDT
Update
We are actively releasing the fix to all accounts. Users who were experiencing an issue with the Contact Page not loading will see the issue resolved shortly.

Next Update: 10:30 PM UTC
Posted about 1 month ago. Aug 14, 2019 - 17:14 CDT
Identified
We have identified the issue causing the Contact Page to not load for some accounts and are working on a fix.

Next Update: 9:15 PM UTC
Posted about 1 month ago. Aug 14, 2019 - 16:38 CDT
Investigating
We are currently investigating reports of the main Contact Page not loading the list of contacts for some users.

Next Update: 9:00 PM UTC
Posted about 1 month ago. Aug 14, 2019 - 16:29 CDT