Planned Maintenence
Incident Report for ActiveCampaign
Resolved
Maintenance has ended.
Posted 8 months ago. Mar 14, 2017 - 18:10 CDT
Monitoring
We're currently monitoring the status of planned maintenance for the platform. Maintenance should be over in about 20 minutes.
Posted 8 months ago. Mar 14, 2017 - 18:01 CDT