Campaign Sending Delay
Incident Report for ActiveCampaign
Resolved
All campaigns are processing again at a normal rate. No further action is required by users.
Posted 13 days ago. Sep 05, 2019 - 14:40 CDT
Monitoring
The fix has been released and we are working on processing through the delayed campaigns. No further action is required by users.

Next Update: 8PM UTC
Posted 13 days ago. Sep 05, 2019 - 14:01 CDT
Identified
We have identified an issue that is causing delays in campaign sending and are working to release a fix. Campaigns are processing, just at a delayed rate.

Next Update: 7:00 PM UTC
Posted 13 days ago. Sep 05, 2019 - 13:01 CDT
This incident affected: Mail Sending Availability.