Delays in automations processing and email campaign sending

Incident Report for ActiveCampaign

Resolved

The issue has been addressed and there should be no further delays in automations and/or email campaign sending.
Posted Sep 09, 2025 - 17:58 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2025 - 17:15 CDT

Identified

Engineers have detected an issue causing campaign and automation processing to be delayed by up to 60 minutes. This issue is impacting accounts in the US data center.
Posted Sep 09, 2025 - 17:15 CDT
This incident affected: US Region (Automations, Campaigns).