Campaign Sending Issues

Incident Report for ActiveCampaign

Resolved

This incident is resolved.
Posted May 22, 2025 - 00:25 CDT

Monitoring

Engineers have implemented a fix for the delays affecting campaigns, imports, and exports. Engineers are actively monitoring as systems recover and workloads normalize.
Posted May 21, 2025 - 22:53 CDT

Identified

Engineers have identified the issue and are working to resolve the issue.
Posted May 21, 2025 - 21:58 CDT

Update

We are continuing to investigate this issue.
Posted May 21, 2025 - 20:27 CDT

Update

Engineers are also investigating issues with imports and exports and are continue to investigate the issue.
Posted May 21, 2025 - 20:15 CDT

Investigating

Engineers are investigating reported issues with campaign sending.
Posted May 21, 2025 - 19:35 CDT
This incident affected: US Region (Campaigns), APAC Region (Campaigns), and EU Region (Campaigns).