Engineers are investigating an issue that is preventing landing pages to load for pages using a custom domain. Non custom domain pages are working as expected.

Incident Report for ActiveCampaign

Resolved

All landing pages are loading as expected.
Posted Nov 20, 2025 - 12:06 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2025 - 11:49 CST

Investigating

We are currently investigating this issue.
Posted Nov 20, 2025 - 11:28 CST