Engineers are investigating an issue impacting accounts created after December 16th 2024. Plan modifications are unavailable at this time.

Incident Report for ActiveCampaign

Resolved

This incident has been resolved.
Posted 28 days ago. Mar 11, 2025 - 23:38 CDT

Update

We are continuing to investigate this issue.
Posted 28 days ago. Mar 11, 2025 - 21:31 CDT

Investigating

We are currently investigating this issue.
Posted 28 days ago. Mar 11, 2025 - 21:15 CDT
This incident affected: APAC Region (ARC & ARC Services), US Region (ARC & ARC Services), and EU Region (ARC & ARC Services).