Engineers have successfully deployed the fix across all systems. Testing confirms that the option to edit advanced searches and segmentations within the Contacts section is now fully restored and operating normally.
This incident is now resolved.
Posted May 19, 2026 - 06:44 CDT
Update
Engineers have successfully identified the root cause of the issue and verified a solution. The fix is currently being rolled out across all systems to restore the ability to edit advanced searches and segmentations.
Another update will be provided once the rollout is complete and functionality is fully restored.
Posted May 19, 2026 - 05:36 CDT
Identified
Engineers are actively investigating an issue affecting the Contacts section. Reports indicate that the ability to edit existing advanced searches and segmentations is currently unavailable. Investigation is underway to identify the root cause and restore full functionality.
Regular updates will be provided as new information becomes available.
Posted May 19, 2026 - 04:15 CDT
This incident affected: US Region (CRM), APAC Region (CRM), and EU Region (CRM).