Tracked links may redirect to a "Site can't be reached" status
Incident Report for ActiveCampaign
Resolved
This incident has been resolved. All links in campaigns are operating as expected.
Posted Jul 05, 2024 - 14:00 CDT
Investigating
We are currently investigating this issue.
Posted Jul 05, 2024 - 12:47 CDT
This incident affected: US Region (Campaigns).