Delays in Campaign Sending, imports, exports, bulk edits

Incident Report for ActiveCampaign

Resolved

The delays campaign sending, imports, exports, bulk edits has been resolved.
Posted Jul 09, 2025 - 13:57 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 09, 2025 - 13:47 CDT

Identified

Engineers are actively working on the issue.
Posted Jul 09, 2025 - 12:25 CDT

Investigating

Engineers have identified an issue impacting campaign sending, imports, exports, bulk edits. These actions could be delayed. Engineers are actively working on the issue.
Posted Jul 09, 2025 - 12:23 CDT
This incident affected: US Region (Automations, Campaigns).