Issue with UI detected
Incident Report for ActiveCampaign
Resolved
This incident is resolve
Posted Aug 30, 2022 - 15:26 CDT
Identified
We've identified an issue with the UI related to site navigation.
Engineers are actively working on a solution.
Posted Aug 30, 2022 - 15:14 CDT
This incident affected: ActiveCampaign.com.