Trial Accounts cannot launch Landing Pages

Incident Report for ActiveCampaign

Resolved

Engineers have released a fix to address the issues impacting the platform. Normal service has been restored for all impacted users.
Posted Apr 28, 2026 - 11:24 CDT

Identified

Engineers have identified an issue preventing new accounts from creating landing pages. Existing landing pages are unaffected. The cause has been identified and a fix is will be deployed as soon as possible.
Posted Apr 28, 2026 - 06:04 CDT
This incident affected: APAC Region (Web Personalization), US Region (Web Personalization), and EU Region (Web Personalization).