ActiveCampaign.com is experiencing access issues.
Incident Report for ActiveCampaign
Resolved
The issues have been resolved and the website is now fully functional. Thank you for your patience.
Posted Jul 29, 2022 - 10:14 CDT
Identified
We are experiencing website issues and will be back online shortly. You can still log in to your account.
We appreciate your patience, and if you need immediate support, contact Customer Support.
Posted Jul 29, 2022 - 10:08 CDT
This incident affected: ActiveCampaign.com.