Issues with trial account creation
Incident Report for ActiveCampaign
Resolved
Engineers have resolved the issue.
Posted Nov 21, 2023 - 09:47 CST
Investigating
Engineers are investigating an issue with new trial creation. Existing customer account operations are unaffected
Posted Nov 21, 2023 - 09:12 CST